Invasion from the Unknown (1.9.99) for Wesnoth 1.4

Discussion and development of scenarios and campaigns for the game.

Moderators: Forum Moderators, Developers

Post Reply
User avatar
Turuk
Sithslayer
Posts: 5283
Joined: February 28th, 2007, 8:58 pm
Contact:

Re: Invasion from the Unknown (1.9.4) for Wesnoth 1.4

Post by Turuk »

Shadow_Master wrote:For future note, this is about the 1.4-compatible version. Many breaking changes have been made since IftU 1.9.4. The previous posts concerning IFtU were moved to the proper thread below.
As noted above, many of the issues/bugs found in the 1.4 version of IftU were most likely fixed in the current 1.5/1.6 version. Shadow_Master has stopped work on the 1.4 for that purpose, and you may be better off playing the more current one. However, he made be able to provide you with a fix to get around the problem.
Mainline Maintainer: AOI, DM, NR, TB and THoT.
UMC Maintainer: Forward They Cried, A Few Logs, A Few More Logs, Start of the War, and Battle Against Time

Soc
Posts: 2
Joined: March 5th, 2009, 8:53 am

Re: Invasion from the Unknown (1.9.4) for Wesnoth 1.4

Post by Soc »

Thanks for reply.
I will try to install wesnoth-svn package from Arch's AUR.

-----------------
Not aviable for x86_64. So I need to wait for original package update. Blah... ;)

User avatar
Iris
Site Administrator
Posts: 6692
Joined: November 14th, 2006, 5:54 pm
Location: Chile
Contact:

Re: Invasion from the Unknown (1.9.4) for Wesnoth 1.4

Post by Iris »

Works For Me (using Wesnoth 1.4.7, IftU 1.9.4 plus changes in the wesnoth-umc-dev SVN repository). Can you attach a saved game that reproduces the problem, please?

I should not be doing more maintenance to this branch, but if you have found a critical bug which I can reproduce, I'll probably make a last release, backporting my and Kitty's artwork from trunk.
Author of the unofficial UtBS sequels Invasion from the Unknown and After the Storm (now available for Wesnoth 1.14).

rotteveel
Posts: 1
Joined: March 12th, 2009, 9:35 am

Re: Invasion from the Unknown (1.9.4) for Wesnoth 1.4

Post by rotteveel »

Hallo Shadow-Master,

I got a bug in IotU - 1 - Cursed Plateau

error Message:

<invalid WML fund>
[ai] the 'simple_targetting' attribute is deprecated, support will be removed in version 1.7.0; use 'simple_targeting' instead

User avatar
Iris
Site Administrator
Posts: 6692
Joined: November 14th, 2006, 5:54 pm
Location: Chile
Contact:

Re: Invasion from the Unknown (1.9.4) for Wesnoth 1.4

Post by Iris »

Thanks, but do not use this thread for reporting bugs in the 1.4 version.

The thread for the 1.5/1.6 compatible version is just a few threads below in the first page of this subforum at the moment.
Author of the unofficial UtBS sequels Invasion from the Unknown and After the Storm (now available for Wesnoth 1.14).

PyroDog
Posts: 1
Joined: April 17th, 2009, 1:00 pm

Re: Invasion from the Unknown (1.9.4) for Wesnoth 1.4

Post by PyroDog »

Great campaign. Easily one of the best I've ever played.
Good job.

Quick question - I'm on the scenario, "Meet your Fate," and I've been trying to slaughter the assault commander. Killed him once, and the hero made a cryptic comment about removing his mask in order to defeat him. Now... I don't want to spend 3 hours trying to kill him only to find out that there is literally no way.

So... is there a legitimate method of defeating the commander besides letting him kill you?
Thanks.

User avatar
Iris
Site Administrator
Posts: 6692
Joined: November 14th, 2006, 5:54 pm
Location: Chile
Contact:

Re: Invasion from the Unknown (1.9.4) for Wesnoth 1.4

Post by Iris »

No.

But you will be able to defeat "him" in "Gauntlet" (IftU 1.9.99 for Wesnoth 1.4) or in "Dark Hive" (IftU 1.12.x for Wesnoth 1.6). Why are you still playing with 1.4 btw? ;)
Author of the unofficial UtBS sequels Invasion from the Unknown and After the Storm (now available for Wesnoth 1.14).

jacko302
Posts: 2
Joined: May 30th, 2010, 12:15 pm

Re: Invasion from the Unknown (1.9.99) for Wesnoth 1.4

Post by jacko302 »

Hey When is there going to be a walkthrough because Im Stuck on the 4th scenario. Also I have the game for the Iphone so could someone make walkthroughs for those?

tribes45
Posts: 123
Joined: June 24th, 2010, 12:40 am

Re: Invasion from the Unknown (1.9.99) for Wesnoth 1.4

Post by tribes45 »

Sucks this campaign is no longer maintained, I can't complete it because of an error :/
"In peace, sons bury their fathers. In war, fathers bury their sons." -Herodotus
"Two things are infinite, the universe and Human stupidity. Although, I'm not sure about the universe. -Albert Einstein

User avatar
Iris
Site Administrator
Posts: 6692
Joined: November 14th, 2006, 5:54 pm
Location: Chile
Contact:

Re: Invasion from the Unknown (1.9.99) for Wesnoth 1.4

Post by Iris »

This topic is for the Wesnoth 1.4 version of the campaign. The latest version is maintained by someone else for Wesnoth 1.10, and has a separate topic like every other version series does.
Author of the unofficial UtBS sequels Invasion from the Unknown and After the Storm (now available for Wesnoth 1.14).

Electra
Posts: 3
Joined: May 19th, 2013, 1:05 pm

Re: Invasion from the Unknown (1.9.99) for Wesnoth 1.4

Post by Electra »

Shadowmaster,
I have been playing Invasion from the Unknown and really enjoy the game. I was able to reach Invasion from the Unknown part 2 campaign "Welcome to my Lair." However, a recent problem has come up with the Aragwaithi warlocks and sorcerers. In the Invasion from the Unknown part 2 campaign "Arrival of the Battlaion" I am unable to recruit.

If I try to play the next campaign "Dawn of the Great War", I am unable to do so because I receive this error message: Error while playing the game: game_error: unknown unit type: Aragwaith Warlock

If I try to play the campaign I was on "Welcome to my Lair", I am unable to do so because I receive the error message: Error while playing the game: game_error: unknown unit type: Aragwaith Sorcerer

I tried removing the campaign and redownloading it from addons, but still had problems.

I have a speculation why this isn't working:
- When I clicked on my Aragwaithi Strongbow in "Arrival of the Battlaion" and looked under the Aragwaithi race:
- the wizard was level 2. It advanced from a witch (not a warlock). It advanced to a sorceress (not a sorcerer).
- As a result, I was unable to recruit in "Arrival of the Battlaion" because of the witch/warlock discrepancy.

Could you fit it please?

Raijer
Posts: 425
Joined: April 25th, 2013, 9:00 pm

Re: Invasion from the Unknown (1.9.99) for Wesnoth 1.4

Post by Raijer »

Are you seriously playing on 1.4? I suggest you check your wesnoth version and go to the forum concerning the campaign on your wesnoth version. The link for 1.10 1.11 should be 2-3 posts before yours.
I am the master of my fate:
I am the captain of my soul.

William Ernest Henley

User avatar
Iris
Site Administrator
Posts: 6692
Joined: November 14th, 2006, 5:54 pm
Location: Chile
Contact:

Re: Invasion from the Unknown (1.9.99) for Wesnoth 1.4

Post by Iris »

@Electra: I think Espreon already contacted you about this?

In any case, if you are actually playing the latest IftU version on 1.10 or 1.11.x (instead of playing the obsolete version this thread refers to on 1.4), yeah, the correct topic is a different one and I’ll move these posts to it later*. The problem is supposedly that your saves starting from turn 1 of Arrival of the Battalion may refer to unit types which have been renamed and removed in the latest version. The best way to deal with that since someone didn’t provide a compatibility path is starting Arrival [...] again from the start-of-scenario save before turn 1.

* And lock this obsolete topic.
Author of the unofficial UtBS sequels Invasion from the Unknown and After the Storm (now available for Wesnoth 1.14).

Post Reply