Wesnoth 1.0 Sarge backport depends on nonexistant package

Having trouble with the game? Report issues and get help here. Read this first!

Moderators: Forum Moderators, Developers

Forum rules
Before reporting issues in this section, you must read the following topic:
Post Reply
Doros
Posts: 78
Joined: October 13th, 2004, 4:02 am
Location: USA

Wesnoth 1.0 Sarge backport depends on nonexistant package

Post by Doros »

I was trying to install the DEBs from the Wesnoth Sarge backport, and I got this error:

Code: Select all

The following packages have unmet dependencies:
  wesnoth: Depends: libzipios++0c102 but it is not installable
Looking at libzipios++0 says that it replaced libzipios++0c102. I know this has to do with the ongoing ABI transition, but shouldn't Sarge packages be unaffected by this?
WildPenguin
Posts: 161
Joined: September 6th, 2005, 10:41 pm
Location: Australia

Post by WildPenguin »

I'm running the lastest wesnoth on my Debian box and have not experienced that error on installation or from any upgrades. I'm currently using Wesnoth 1.0 with libzipios++ 0.1.5.9+cvs. Grabbing a copy of libzipios++ equal to, or later than this version should solve the problem. :)
Doros
Posts: 78
Joined: October 13th, 2004, 4:02 am
Location: USA

Fixed

Post by Doros »

Okay, I figured out what it was, and it was my own silliness. I got so used to calling testing Sarge, I mistook the Sarge packages for testing packages, and I'm actually running testing. I installed the official packages from unstable, and they work fine.
Post Reply