Search found 537 matches

by Sithrandel
November 21st, 2005, 4:09 pm
Forum: Technical Support
Topic: Help with the campaign editor
Replies: 2
Views: 587

Re: Help with the campaign editor

Hey, I just started trying to build a campaign in the editor that's part of the game and I've run into a problem - when saving or opening a campaign I get the "loading/saving" dialog and it just sits there forever without doing anything. Otherwise the editor seems to be good. I'm on a mac with os 1...
by Sithrandel
September 23rd, 2005, 4:50 pm
Forum: Release Announcements, Compiling & Installation
Topic: First Wesnoth 1.0 release candidate
Replies: 83
Views: 26763

If you want to be able to handle distinct code for distinct Mac OS X versions, you could try to use the _ENVIRONMENT_MAC_OS_X_VERSION_MIN_REQUIRED_ macro (based on MACOSX_DEPLOYMENT_TARGET environment variable set by Xcode) Conditional compilation based on OS version or configure is very un-mac lik...
by Sithrandel
September 23rd, 2005, 3:46 pm
Forum: Release Announcements, Compiling & Installation
Topic: First Wesnoth 1.0 release candidate
Replies: 83
Views: 26763

scott wrote:If it helps, I put 10.3.0 as the system requirement for apple.com. I figure since whatever I put can be a big crapshoot anyway, it's better to let people down easy rather than get their hopes up.
Yes it does... I think once 1.0 is out it will be time to go to 10.3+ :)
by Sithrandel
September 23rd, 2005, 3:29 pm
Forum: Release Announcements, Compiling & Installation
Topic: First Wesnoth 1.0 release candidate
Replies: 83
Views: 26763

Interesting stats there :) Seems that 10.2.8 is definitely a minority. As Wesnoth doesn't require the latest hardware I wasn't sure if there would be a large number of non-upgraders out there. Looks more and more like moving to 10.3. wouldn't cause to much hassle and we could kiss a few #ifdef __APP...
by Sithrandel
September 23rd, 2005, 8:52 am
Forum: Release Announcements, Compiling & Installation
Topic: First Wesnoth 1.0 release candidate
Replies: 83
Views: 26763

Sithrandel Mac Binary is now at: http://prdownloads.sourceforge.net/wesnoth/Wesnoth_MacOSX_1.0rc1.dmg?download It would be very helpful to hear from any Mac users still using 10.2.8 as to whether this works. If it turns out there aren't any 10.2.8 users left then it would make sense to increase the ...
by Sithrandel
September 8th, 2005, 3:45 pm
Forum: Release Announcements, Compiling & Installation
Topic: Wesnoth 0.9.7
Replies: 23
Views: 13192

scott wrote:You mean 0.9.7
So I did :oops:
by Sithrandel
September 8th, 2005, 3:40 pm
Forum: Release Announcements, Compiling & Installation
Topic: Wesnoth 0.9.7
Replies: 23
Views: 13192

Another MacOSX version is up at:

http://prdownloads.sourceforge.net/wesn ... g?download

Let's spoil them for choice this time... after all they deserve it for the occasional long waits :D

[edited to take into account Scott's fast error pointing!]
by Sithrandel
September 2nd, 2005, 1:15 pm
Forum: Users’ Forum
Topic: Startup problem on Mac.
Replies: 12
Views: 1590

C++ don't compile with SDK 10.2 enabled. I've tried it. As you've probably imported the project from a previous Xcode, maybe the setting are not propagated for your converted target or maybe the SDL kind target don't care of SDK. Incorrect. C++ compiles perfectly well with the 10.2SDK. The target s...
by Sithrandel
September 2nd, 2005, 9:21 am
Forum: Users’ Forum
Topic: Are you running 0.9.6 on Mac OS X 10.2.8?
Replies: 0
Views: 535

Are you running 0.9.6 on Mac OS X 10.2.8?

I'm just trying to work out how 0.9.6 is working on 10.2.8... and how many 10.2.8 punters there are trying to run it :)
by Sithrandel
September 2nd, 2005, 9:18 am
Forum: Users’ Forum
Topic: Startup problem on Mac.
Replies: 12
Views: 1590

If it is build with the project I found into the image, the SDK isn't used as far I know. I can't say for sure with the latest version of XCode as I have not investigated fully. I can, however, state that: * In previous versions of XCode the 10.2SDK was essential to maintain compatibility for Wesno...
by Sithrandel
September 1st, 2005, 4:55 pm
Forum: Users’ Forum
Topic: Startup problem on Mac.
Replies: 12
Views: 1590

It's supposed to work with 10.2.8, and a previous version (but later than 0.9.2) was reported to have worked with 10.2.1, but you might be out of luck. The version of 0.9.6 on the downloads page: http://www.wesnoth.org/downloads is compiled with the 10.2.8SDK so should work (theoretically with 10.2...
by Sithrandel
August 30th, 2005, 2:00 pm
Forum: Release Announcements, Compiling & Installation
Topic: Wesnoth 0.9.6
Replies: 34
Views: 14657

lwa wrote:Did you merged the bug fixes and improvements I added in my builds of 0.9.5 ?
I haven't had the time to look at the changes you have made... so no. When I have the time I'll have a look at them :)
by Sithrandel
August 28th, 2005, 10:45 pm
Forum: Release Announcements, Compiling & Installation
Topic: Wesnoth 0.9.5
Replies: 73
Views: 18755

Disto wrote:I don't believe there will be a 0.9.6 it's 1 next.... as they were aiming for 1 to be in the 3rd of September i don't see why they've released 0.9.6.
Version 0.9.6 is up now :)
by Sithrandel
August 28th, 2005, 10:42 pm
Forum: Release Announcements, Compiling & Installation
Topic: Wesnoth 0.9.6
Replies: 34
Views: 14657

by Sithrandel
August 25th, 2005, 3:00 pm
Forum: Users’ Forum
Topic: version 0.9.5 trouble
Replies: 15
Views: 2240

Ankka wrote:Oh, the official version is out, seems.
If I remember correctly, there is no official binary ;)

But FWIW my build has been uploaded.